PPTools/Guiguts/Guiguts Manual/Shortcuts Reference Card

From DPWiki
Jump to navigation Jump to search

[See end of this page for printing options.]

Moving the Cursor (See Navigation page for more details.)
 Home -- Move cursor to left end of line.
 End -- Move cursor to right end of line.
 <ctrl>+Home -- Move cursor to top of file.
 <ctrl>+End -- Move cursor to end of file.
 <ctrl>+right/left arrow -- Move cursor to next/previous word.
 <ctrl>+down/up arrow -- Move cursor to next/previous paragraph.
Delete Word
 <ctrl>+<backspace> -- Delete word backwards from cursor.
 <ctrl>+<delete> -- Delete word forwards from cursor.
Delete to End of Line
 <ctrl>+k -- Delete from cursor to end of line.
Undo, Redo (See Edit Menu page for more details.)
 <ctrl>+z –- Undo.
 <ctrl>+y –- Redo [also <ctrl>+<shift>+z].
Selecting Text (See Edit Menu page for more details.)
 <ctrl>+a or Edit>Select All -- Select entire file.
 double-click -- Select word at cursor.
 triple-click -- Select line at cursor.
Copy, Cut and Paste (See Edit Menu page for more details.)
 <ctrl>+c -- Copy [or column copy].
 <ctrl>+x -- Cut [or column cut].
 <ctrl>+v –- Paste.
 <ctrl>+<alt>+v -- Alternative paste method to avoid a Perl bug.
Column Select (See Edit Menu page for more details.)
 <shift>+mouse-drag -- Column select.
 F1 -- Column copy.
 F2 -- Column cut.
 F3 -- Column paste.
Highlighting Characters in Selection (See Navigation page for more details.)
 <ctrl>+, -- Highlight all apostrophes in selection.
 <ctrl>+. -- Highlight all double quotes in selection.
 <ctrl>+<alt>+h -- Highlight arbitrary characters in selection.
 <ctrl>+; -- Toggle highlighting of quotes and brackets around cursor.
 <ctrl>+<shift>+a -- Toggle highlighting of vertical column at cursor.
 <ctrl>+0 -- Remove all highlights.
Extending the Selection (See Edit Menu page for more details.)
 Holding the Shift key while using an action to move the cursor will
 extend the selection from the current cursor position;
 e.g. <shift>+End extends selection to end of current line.
Bookmarking (See Navigation page for more details.)
 <ctrl>+1,2,3,4,5 -- Go to bookmark 1,2,3,4,5.
 <ctrl>+<shift>+1,2,3,4,5 -- Set bookmark 1,2,3,4,5.
Rewrap Selection (See Tools Menu page for more details.)
 <ctrl>+w -- rewrap selection.
 <ctrl>+<shift>+w -- block rewrap selection.
Indent Selection (See Text Menu page for more details.)
 <ctrl>+m -- Indent +1 / move column selection right [also <alt>+right arrow].
 <ctrl>+<shift>+m -- Indent -1 / move column selection left [also <alt>+left arrow].
 <ctrl>+<alt>+m -- Indent +4.
 <ctrl>+<alt>+<shift>+m -- Indent -4.
Quick-count of Highlighted Word(s) (See Navigation page for more details.)
 <ctrl>+<shift>+b -- Quick-count number of matches of highlighted word(s).
Search & Replace (See Searching page for more details.)
 <ctrl>+f -- Open Search & Replace popup.
 <ctrl>+g -- Continue search.
 <ctrl>+<shift>+g -- Continue search in opposite direction.
 <ctrl>+b -- Count number of matches.
Flood Fill / Surround Selection (See Edit Menu page for more details.)
 <ctrl>+e -- Flood fill (if popup is open, otherwise open it).
 <ctrl>+r -- Surround text (if popup is open, otherwise open it).
Convert Case of Selection (See Edit Menu page for more details.)
 <ctrl>+u -- Convert case of selection to UPPER CASE.
 <ctrl>+l -- Convert case of selection to lower case.
 <ctrl>+t -- Convert case of selection to Title Case.
Task Bar Functions - Keyboard Shortcuts (See Navigation page for more details.)
 <ctrl>+i -- View current image.
 <ctrl>+j -- Go to line.
 <ctrl>+p -- Go to page.
 <ctrl>+<shift>+p -- Go to page label.
Compose Characters (See Tools Menu page for more details.)
 Right Alt / Alt Gr -- compose character with keystrokes [<ctrl>+m on Mac].
Function Keys (See Tools Menu page for more details.)
 F1, F2, F3 – See Column Select above.
 F5 -- Open Word Frequency.
 F6 -- Run Bookloupe.
 F7 -- Spell check selection (or document, if no selection made).
 F8 -- Open Stealth Scannos search.

A full list of every keyboard shortcut can be found in the manual "Help Menu" section.


This page can be printed on a single side of paper or card as follows:

  1. Position the page on the screen so you can see the sidebar text then click the "Printable version" link under "Tools".
  2. Select correct paper size (A4 or Letter) in the print dialog.
  3. If the print dialog is not showing all the settings, expand "More settings" / "More options".
  4. Set "Margins" to "Minimum" if allowed. Don't worry if it reverts to "Default" in the next step.
  5. Set "Scale" to a custom value large enough to read comfortably but small enough to fit text on one side of paper.
  6. For large values of "Scale" (150-200) set "Pages per sheet" to "2"; it should automatically switch to Landscape orientation.
  7. Turn off "Headers/footers"
  8. When the preview looks good, click "Print"

Browser Issues

  • Firefox (Windows/Mac/Linux) - Don't use its "Simplified" print format.
  • Safari (Mac) - Cannot cannot handle 2-up printing with enlargement of text.