PPTools/Guiguts/Guiguts Manual/Preferences Menu

From DPWiki
Jump to navigation Jump to search


GUIGUTS VERSION 1.5.0 MANUAL

Preferences

The sub-menus of Preferences give you dozens of ways to tailor Guiguts. You will set most of them only once, but may find it desirable to change the Preferences>Processing>Set Rewrap Margins to optimize indentations for different projects.

Gg1.2-51a-preferencesmenu.png


File Paths

Gg-1.4.1-51b-file paths submenu.png

These are one-time settings, and Guiguts will have set most of them for you during installation.

  • Set File Paths: These are the locations of the External Programs used by Guiguts. The tools packaged with Guiguts are in its tools folder, and the pre-defined paths to them normally do not need to be changed. If necessary, you can use the Locate buttons to bring up a standard Directory/File dialog, and walk through it until you've found the needed program.
    • If the distribution defaults for the Image Viewer and Aspell shown in this example do not work on your system, you can use Locate to change them. For example:
      • If your Image Viewer is IrfanView, its 64-bit version's default location is:
        C:\Program Files\IrfanView64\i_view64.exe
    • The Scannos folder is handled differently from the other paths, all of which identify a specific executable file. This setting just identifies a folder, so If you set up your own custom scannos folder, make sure its name does not end in "scannos", or the next time you start Guiguts the setting will revert to the default "scannos" folder included with Guiguts. For example, you can call your custom folder "scannos_custom", but not "custom_scannos". This behavior is a consequence of Guiguts' attempt to make it easier when upgrading from one release to another.
      • If you use the default "scannos," you won't need to change it, but if you've modified any of the .rc files in that folder, please remember to copy them to the "scannos" folder of each newly-installed version.
Gg-1.5.0-51c-file paths submenu.png


  • Set DP URL's: The addresses of these standard DP web pages should be correct as-is. Note: Your current project ID is appended to each URL by an option in the File>Project menu. Other options in that menu will then allow you to view in a browser window the project's main page, its comments section and its discussion forum.
Gg1.2-51d-dp urls.png
  • Copy Settings from a Release: This option copies setting.rc and header.txt from the version of Guiguts you had been using to a fixed, known location that all future versions of Guiguts will be able to use. It also copies your user global Spell Query dictionaries, and language labels files which may have been customized. It will display a standard File Dialog, and you can navigate to the main Guiguts folder you've been using and select it. A dialog will pop up warning you that Guiguts is about to exit, and that it will use the newly copied settings next time you start the program. Once this operation has been done, you won't have to transfer settings again. You don't have to use it if you prefer to continue transferring settings as you've done in the past, and you can use it at any time if you decide to do so.
    • Advanced Management of Settings: Most users will not need to use the following advanced features to manage the folder from where Guiguts accesses setting.rc and header.txt.
      • Default settings folder locations: If the Copy Settings from a Release option described above is used, settings will be stored by default in the following locations:
        • Windows and Mac systems: Your HOME folder \ Documents \ GGprefs. In Windows, this is: %HOMEPATH%\Documents\GGprefs\
        • Linux systems: $HOME/.GGprefs
      • If the argument --home foldername is given when you run Guiguts, e.g. perl guiguts.pl --home \DP\GGsettings, then for this run of Guiguts only, the given foldername will be used instead of the default described above. If the foldername does not exist, it will be created, and copies of settings files from the current release will be copied to it.
      • If the argument --nohome is given, then for this run of Guiguts only, it will use settings files from under the release, even if a settings folder has been set up previously.

Appearance

These should be self-explanatory, and the defaults are satisfactory in most cases:

Gg-1.3.2-51e-appearance submenu.png


Fonts

Gg-1.3-51e-appearance submenu fonts.png
  • When choosing a font for Guiguts' Main window, it's best to use one that is monospace, as that's the only way to align table columns in Plain Text. Two good monospace fonts are Courier New (a standard font) and DP Sans Mono, a font designed for extra clarity and recommended for use when proofreading and formatting. If you've been Proofing and/or Formatting at DP, you've probably installed that font already; otherwise, you can learn more about it and how to download it HERE. You can choose the same font or other fonts for the Unicode Menu and for the many text entry fields in various Dialog boxes.
  • If you turn off "Use System Defaults..." you can select other fonts and/or sizes for the small text entry boxes and most of the menus and buttons throughout Guiguts. These overrides are particularly useful when you want to use larger or bolder fonts.



Toolbar

Gg1.2-51f1-toolbar submenu.png

This sub-menu lets you choose where, if at all, to place the Tool bar ("yes, at the bottom" is the default), and whether or not the Status bar should display the name as well as the value of the character to the right of the cursor.


Backup

Gg1.2-51g-backup submenu.png

If you want Guiguts to Auto-save save your work, use this sub-menu and optionally set the interval (the default is 5 minutes, but Auto-save itself is not enabled by default). If you want Guiguts to make backups of the .bin and .html/.txt files when it Auto-saves, also select the "Keep a Backup Before Saving" option.

The background of the "Save" icon |Guiguts Tb-save.png on the Toolbar is green when Auto-save is enabled, and flashes yellow for several seconds before an Auto-save begins. Right-click the icon to reset the Auto-save timer to start counting again. Shift-right-click (Mac: shift-ctl-click) to toggle the Auto-save option on/off.

When you do a manual Save, Guiguts makes backups of the .bin file, or backups of the .bin and .html/.txt files if "Keep a Backup Before Saving" has been selected on this Preferences|Backup sub-menu.

Guiguts keeps up to three generations of backups; this number is not user-selectable.


Processing


Gg-1.4.0-51h-processing submenu.png

This is a collection of miscellaneous settings and options, some of which affect other menus, and some of which display dialogs that can be accessed in other ways.

  • Auto Set Page Markers on File Open: When this option is set (which it is, by default), when Guiguts opens a file that still contains Page Separators, it uses those markers to identify the page breaks and synchronize the text to the page images. This overrides the information already in the .bin file if one was created by an earlier save. Once the Page Separators have been removed, this option becomes non-functional.
  • Track Operations History: When set, Guiguts will maintain a log of the tools you've used, and you can view that with File>Project>View Operations History.
  • Filter Word Freqs Intelligently: In Word Frequency's Word Check, when you use the Check , Upper button, it won't report that a capitalised word follows a comma if the word comes at the end of a sentence (i.e. period, ? or ! after it) or is the second word of a sentence. Examples: "Isn't that strange, Mary?" and "Hi, Mary, how are you today?"
  • Set Threshold Word Count for Marked Up Phrases: Word Frequency's
    noframe
    Italics/Bold/SC/etc button finds tagged words and phrases containing no more than the number of words specified by this pop-up dialog. The default is "4", so a five-word italicized phrase will not be listed. The same popup appears whether you use this menu option or the button in Word Frequency. Setting the threshold to zero means there will be no limit, potentially allowing an entire paragraph to be included.
  • Include Two Words ('flash light') in Word Frequency Hyphen check: When this is not set (by default), Word Frequency's Hyphen Check will only report suspects when you have both "flashlight" and "flash-light". When this option is set, it will also report "flashlight" and "flash light", or "flash-light" and "flash light" (or all three variants if you have them).
  • Return after Failed Search: By default, when Search & Replace doesn't find anything, it leaves the text window either at the top of the file or (if Reverse is set) the bottom. When this option is set, S&R leaves the text window about where it was. The cursor may be a character or two off from its previous position.
  • Set Search History Size: This shows a small dialog; the default is 20.
  • Sticky Search Options: By default, The Search and Replace options just below the Search line ("Case Insensitive", etc.) are remembered and used each time you open that Dialog. If you want all of those options to be off each time the Dialog opens, turn off "Sticky."
  • Set Spell Check Options: This displays the same dialog as does the button on the Tools>Spell Check dialog.
  • Leave Space After End-of-Line Hyphens during Rewrap: This may be useful in some situations, but you usually will be using Tools>Remove End-of-line Spaces, and that will remove these spaces, too.
  • Set Rewrap Margins: You probably will change some of these indentations for many projects. Most of them are self-explanatory. The last one, "Right Margin Max.-Opt. Diff," tells the Rewrap Algorithm how flexible to be.
    Gg1.0-51j-set rewrap margins.png
  • CSS Validation Level 2.1: When not set (the default), the CSS Validator on the HTML menu uses CSS3. When this was written (July, 2020), Project Gutenberg only accepted a restricted subset of CSS3 and most handheld devices had limited or no support for CSS3. Setting this option tells Guiguts to validate for CSS 2.1, which has fewer features, is more likely to be accepted by PG, is more likely to work with handheld devices, and was the DP/PG standard for many years.
  • Gg1.2-51k-setcomposekey.png
    Set Compose Key: The Compose Key displays a dialog that lets you quickly insert any Unicode character at the current cursor position. By default, the key that brings up that dialog is the right-side Alt key or Alt-Gr. That default may conflict with other uses you have for that key, and this option lets you change it with this dialog. Except for F1, whatever key(s) you press while this is displayed will appear as the activation key(s) from now on.


  • Allow px Sizes for HTML Images: When this option is selected, the HTML->Auto Illus Search->Image Selection dialog will offer an option to use pixels as the width unit in the generated <div> information.